More Concours Prep. The Untold Story

Posted on 25 Aug 10:11

Before we dropped the 85 Quattro off at Auto Europe for detailing we had been trying to diagnose some running issues. Basically the car would hesitate when transitioning onto boost but otherwise ran pretty good. There are no real diagnostics on these cars and the CIS injection we find baffling but thought we could troubleshoot it. We went ahead and bought a CIS fuel pressure tester kit to check the various fuel pressures in the system. 

These fell a little short of optimal so we replaced the fuel pump and fuel filter That did not help much but did make a marginal difference. 


We also tested fuel delivery. We had plenty. So, with Auto Europe also being the home of famed Audi guru Phil we suggested they take a look while they had it in for detailing. Well that escalated fast. Phil quickly diagnosed that the frequency valve was not pulsating. He fixed a dodgy previous owner splice in the wiring but unfortunately that didn’t bring it back to life. He then attacked the wires at the ECU end and discovered some disturbing previous owner hacks. Firstly there were a bunch of wire nut splice adjacent to the ECU. Then he realised the vacuum input had been tee’d and there were now two inputs! It didn’t get any better once he got into the ECU either. There was a second, aftermarket vacuum switch piggy backed onto the original and various pins on the chip were soldered together! Clearly a new ECU was needed to make this car run as intended by the factory. 

 

They managed to find a un-touched and supposedly working ecu from the same year car and threw it in just hours before we picked up the car to take it over to the concours. The car did indeed run and idle much more smoothly than before but exhibited a big backfire the moment it went from vacuum to boost. It also now will not run pat 4000rpm, an issue normally associated with a bad intake air sensor. That was all tested and the wiring repaired during the engine reseal project so it’s probably ECU end related. The backfiring stopped when we disconnected the cold start valve. It appears the ecu is using the that to add fuel on boost; way too much fuel. So that is where we are now: the car idles and runs great up to 4000rpm but then the ecu cuts fuel. We may just drive it like this till the season ends and then let Phil have at it as this car has been off the road far too much these past few years. Let’s see how that goes.